Skip to main content

Support

Contact the IT Service Desk for help using CULearn or to report any issues or problems.

Web browser compatibility

CULearn supports the current version of the most popular web browsers.

  • Internet Explorer
  • Firefox
  • Chrome
  • Safari

For more detail about browser versions, Java, and Adobe Flash requirements, see the Saba Information Center.

Note: Your pop-up blocker won’t interfere with most courses. If you do need to allow pop-ups, the system will let you know.